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PowerSchool/Teachers Training
LOWER MERION SCHOOL DISTRICT

POWERSCHOOL/TEACHERS
Logging in

URL: http://powerschools.lmsd.org/teachers

Usermame:

Password:

f Enter )

Enter your username in the top box and password in the lower box then click on the Enter button or your Enter
key on your keyboard and a screen similar to the one below will appear:

0

. >{:
i

|
1(A) Attendance (AM) ﬁ"

-

Green bhutton

R = means

2R Attendance () |9 A = attendance
has been

W4 taken and

29(A) Personal/Social skills 1c A ﬁ recorded

3(A) Religion ic

S(A) Reading/Literature 1c /‘\ ™
. N . —

&(A) English 1c /\ it

T(A) Vocabulary/Spelling 1ic

A

Al

8(A) Mathematics 1ic

%

i

Notice only the classes vou teach are listed.
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LOWER MERION SCHOOL DISTRICT

Attendance

=R

The “Chair” icon is used to take attendance in PowerSchool L] |

HE g

First, select the correct Attendance code from the drop down menu at the top then click in the box to the right of
the student’s name. When you have designated all appropriate students click “Submit.” Students are assumed
Present—You do not need to mark a student “Present.” If all students are present just click Submit. This will
inform the administration that you have taken attendance.

Homeroom Grade 8 - HR1{Mon-Fri} HR2{Mon-Fri)

Current attendance cocE: A Absent) v

AAdA S hueiskima~ B

After you have clicked SUBMIT a green dot will appear that confirms attendance has been recorded for this
class.

£ R 4 ..
1(A) U.S. History y ) \ =) —
o ./\ s ™

N, A L
3(B) Current Affairs >& 1%,.\ :
v, I h‘ '_-
- \\%“ = =

4(A) U.S. Histor - ) )
w om Y A =

The knife and fork icon is used for submitting lunch counts.
Final Grade Entry — Standards (for Standards Based Report Cards only!)
If you wish to use the Web-Gradebook you will not be able to use this to enter only a FINAL GRADE.

Click on the Backpack icon (This 1s where most of the information resides in PS/teachers).

Click on the last name of the first student and another screen will appear. Y ou can now use the drop down
menu -- on the right at the top -- to select Final Grade Entry Standards. Next, click on the first name of each
of the following students for the same screen to appear.

Computer TG !



PowerSchool/Teachers Training
LOWER MERION SCHOOL DISTRICT

When you select the Final Grade Entry Standards option you are now able to select the Standards scores for
cach student in each SUBJECT. Y ou can switch classes on the lower left frame of this screen. BE SURE TO
CLICK SUBMIT after entering Standards scores!!

6.PG - Personal Growth and Community Anareness
6.PG.1 - Respects the Rights and Property of Others E v
6.PG.2 - Cooperates with Others SA v
6.PG.3 - Carries Out Responsibilities SA v
6.PG.4 - Complies with School Policies SA v
6.PG.5 - Integrates Characteristics of Justice and Peace in Daily Activities E g

€ submit )
Entering Standards for an entire class
In addition to the Final Grades Entry Standards above, you can enter all Standards for a specific class by

clicking on the (m) next to the Standards Summary (m) on the lower left frame. This will allow you to assign
all standards for a specific class

Standards Summary - T1

Students 6.PG.1 6.PG.2 6.PG.2 6.PG.4 6.PG.5
Curry, Penny |[E & ||SA ¥||SA ¥||SA V|| E ¥
pisney. walt |[E % ||SA ¥||| ~||E ¥||E »

Li, Ellen ¥ SA ¥ |E %||SA v||E ¥| SA ™
Smith, John SA ¥ [SA ¥i[(M w[I N E B8

Smith, Ronald |SA ~ [SA v ||SA ¥||SA v ||E ~

£ Submit 3

Drop Down Menu Items (top right)
1. You can select demographic information
2. Attendance Information

3. Net/Phone Access Summary (Date and duration of when a parent has accessed their child’s information)
4. Print reports (if any reports are available)

Quick Look Up

Quick Look Up allows you to access grade or attendance information for each student in your classes.
Click on any grade appearing in any trimester and you are able to view all assignments within a particular
subject.
Schedule

Allows teachers to view a student’s present schedule

Computer|TTG 5
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LOWER MERION SCHOOL DISTRICT

Standards

Screen allows teachers to view current standards associated with this student. If yvour district does not
use Standards — you will not be able to view this option!

Notice on the bottom of the left frame: Standards Summary (m). If you click on the (m) it allows you to
record Standards for the entire class. Clicking on the link “Standards Summary” allows vou to view all
recorded standards. You can choose to print this screen for your records.

Student Photo

If a student’s photo has been installed in PowerSchool you would be able to view it here.

Teacher Comments

IMPORTANT!!! — Teachers MUST choose either PowerSchool/Teachers OR PowerTeacher (Web
Gradebook) to input Teacher Comments!!

If a teacher is using the Web Gradebook --Teacher Comments MUST be entered through
the Web Gradebook!!

Click on the Back Pack icon of your Home Room or Attendance class > Click on the last name of the
First Student > at the top right pop up menu choose Teacher Comments > click on the EDIT button >
At the next screen Select your Comment from the list on the left (see below) > click on the arrow to
add your comment to the Box on the right > SUBMIT > Click on the First name of the next student and
REPEAT until all comments have been entered.

Teacher Comments will not appear on Report Cards until grades have been made “Historical” or
“Stored.” Grades are stored by your school administrator.

Cumulative or Term Grades
Grades will not appear until grades have been stored.

The Printer icon allows you to print reports. You must make any reports you have created available to the
teachers first.

Computer|TTG 6
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Start Page button will take you back to the first page after you log in.
r Start Page
Daily Bulletin Daily Bulletin button allows your administrators to communicate with teachers and
Staff Directory parents.
Meals

Staff Directory button allows you to view information about your colleagues.

Bersonalize Information must exist in PowerSchool before any information can be viewed here.
Gradebook
Reports Meals button allows you to view your lunch balance if your school uses PowerLunch.

Personalize button allows you to change your password and set up the page most useful to you after you log on.
It can be helpful to set your student screen to Final Grade Entry during Report Card time.

Gradebook button takes you to a screen that allows you to LAUNCH GRADEBOOK button.

Reports allow you to print reports that have been made available to you by your school’s PowerSchool
administrator.

Help Button at the top right part of your screen next to the Logout Button can answer many questions. Please be
sure you are located on the page you wish to receive information about. Then click on the ? symbol for more
information.

m-?

Computer|TTG 7
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POWERTEACHER WEB GRADEBOOK

1. Java version 1.5 or 1.6 should be installed on all teachers’ computers.

2. Port 7880 should be opened at your school’s Firewall and/or Content Filter. If you are using SSL then
port 7443 should be opened.

After logging into PowerSchool/Teachers click on the button, on the left, marked GRADEBOOK.

Personalize | ‘

[ Gradebook ‘

L= N

On the next screen, click on the LAUNCH GRADEBOOK icon to open your Gradebook.

I"aunchiGradebook

You may be prompted to Start or Run or Save, depending on your browser version in order for your
Gradebook to launch successfully.

You will see a “Java Loading” applet opening (see figure below). If your browser screen changes to a “Page
Cannot be displayed” or Internet Explorer cannot open this page — please check that you have Java version 1.5
or 1.6 loaded onto the computer (Start > Control Panel > Java > about) AND that port 7880 or 7443 (SSL) has
been opened in your network. If you are attempting to open the Gradebook from home be sure to add the site to
your trusted sites.

PowerTeacher Gradebook Launch

O
o
E

5

[0

[

0O o 3
l'l

l'l

/ ™ =
=> Java" Loading...

= lEACN NG and IEAIN NG DrOCEas
the teaching and learning process
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LOWER MERION SCHOOL DISTRICT

Gradebook Elements
Classes — TOP LEFT - This 1s the list of classes. Click once on a class to select.

Groups —-BOTTOM LEFT — Create, Modity Groups here by clicking on +.

Filters/Sorting Tools — Reporting Term, Category, and Students
Sorted by choosing one or more of the drop down options

¥ PowerTeacher Gradebook: Penny Curry - Rockyille Example School

File Edit View Tools Window Help
Classes sy 02 N - 8
= = 7 v ".\‘5:; o L i " ‘._- \
Current Classes (T1) =2, N \rﬂvf B ‘ \
Bl HRL(M-F) Homeroom Grade 6 il — —
ﬂ 2(F) S(Th) HR2(M, W) 7(T) Engl Scoresheet  Assignments  Students  Grade Setup  Class Info Reports
ﬁ] 1(w) HR2(Th) 7(T) Social Studi Filter By: PReporting Term: Category: Students:
() 2(7,Th) 4(w) Mathematics Grag
i «(7) 5(w) 7(F) English Languag /' /' /
ﬁ] 2{W,F) English Language Arts Filters E
i Rz echnoloay Grade 6 Filters Filters
Classes Student Final Grade (F1) |||
<4 It J % |Curry, Penny (5] -- A
= Student Groups |ll|Disney, walt 1+
Entire Class Li, Ellen [+ ]
Mouse, Mickey Qo
Sraith, John [+ ]
Smith, Jones [
Srith, Ronald (5]
Smith, Student2 Q
Smith, TrustingZ [+]
Student, Test 15 ]
Studernite, Neww (5]
Testing, Student [+]
/'
Add Groups
P " Enter Scores
v
Revert I Save

Computer TG ’
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ICONS used for Navigation

Add/Delete

—  Adds or Deletes -- Assignments, Groups

Qe i :
BN  Hide / Show button Closes a portion of the frame or Shows the frame

tevert to previous Save | SAVE k Revert H Save

Revert to previous Save or SAVE your work

¥ PowerTeacher Gradebook: Penny Curry - Rockville Example School
File Edit

View Tools Window

Show/Hide

Current Classes (T1) REE—=re

\ =R
Fom IR T
—

P Hr 1{M-F) Homeroom Grade &
(| 2(F) S(Th) HR2(M, W) 7(T) Engl
ﬂ 1) HR2(Th) 7(T) Social Studi Fiter By: Reporting Term: Cateqgory: Students:
i) 2(7,Th) 4(w) Mathematics Gra
ﬂ 4(T) s{w) 7(F) English Languag
ﬂ 2(W,F) English Language Arts
E| HRZ{W) Technology Grade &

Add or Delete

Student Final Grade (F1) |||

g ? |Curry, Penny
Student Groups ||| |Disney, Walt
i ass Li, Ellen

. Mouse, Mickey
Show/Hide Smith, John

Smith, Jones
Smith, Ronald
Smith, Student2
Smith, TrustingZ
Student, Test
Studente, Neww
Testing, Student

|

000000000000

Save/Go Back

Add/Delete

|

Show/Hide M

Computer TG
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CATEGORIES

Top menu choose TOOLS > CATEGORIES

Cat . I
= . awegory 2. Modify an existing Category L
(&) Quiz
F)]I Test Name: | Project
3 Abbreviation: |PRO]
4, Color: EI Violet v
These options will be applied as defaults to any new assignments
whe=r ~reated For this category,
Points Possible: 0
Score Type: .Pnints 6. v.
7. Include in Final Grade:
|
Description:
8.
1.
| A
: _.'f -
Create or Delete a Cateqory [ Cancel ] [ Close ]

Add or Delete a
category by
clicking on + or —

Modify an existing
category by
double clicking on
a category name
and then change it.

Give the category an
abbreviation.

Assign a color to the
category

Assign a default
points possible to
the
ASSIGNMENTS
within the
category. You can
always change this
within each
assignment,

6. Assign default Points, Letter grade or Percentage for the assignments in this category
7. Include or exclude an assignment from calculating in the final grade.
8. Give a description to your category. This will be viewable within Quick Look Up.

9.  Select the name of the next category to modify OR click on the + to add a new
category

10. Click on Close after all categories have been modified!

Computer TG




ASSIGNMENTS

PowerSchool/Teachers Training
LOWER MERION SCHOOL DISTRICT

1. Can be created three ways-- by clicking on Scoresheet icon (at top) and clicking on the “ + * directly
under the Reporting Term filter OR by--Clicking on Assignments icon (at top) and then clicking on * + *
at bottom of frame. OR — Clicking on View > Assignments in the top Menu bar and click on *“ + * at

bottom of frame.

2. Be sure you are in the correct reporting term.

3. Delete an assignment by clicking once on the name of the assignment while in the Assignments view

‘.

and click onthe “ —°

S S
s f = ==

= -

Revert

Scoresheet  Assignments ’ Students  Grade Setup  Class Info Reports
Fiter By: Reporting Term: F1 v Category: ALL v
Narme Abrv Category A  Points Possble  \Weight Date Due
Chapter 1 ©chi T Test 100 1.00 09/15/2007 Sat
List of assignments will appear here.
ot | -
20 New Assignment
Assignment
Name: | Egypt Project Abbreviation: Egypt Pro
2. Category: | 1) Project v 6.  Score Type: Ponts
Points Possible: | 100 7. wWeight: 1.00
4. Date Due: | 09/15/2007 Include in Final Grade: [? g
Description: Project on one of the main areas we studied in Ancient Egypt
9.
10.

1

Computer TG

10.

11.

Name the
assignment.
Select a category
Assign a points
possible

Enter the date
due.

Abbrewviate the
name of the
assignment.
Score by points,
letter grade or
percentage.
Assign a weight
to the
assignment.
Include or
Exclude the
assignment.
Enter a
description
SAVE the
assignment or
Revert to the
PIEVIOUS save.
PUBLISH tab-
publish
immediately or
on a specific
date. In order for
an assignment to
calculate in the
final grade it
must be
published. An
assignment that
is not published
will not be
included in the
final grade!
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COPYING ASSIGNMENTS TO OTHER CLASSES

Click on the Assignment Icon and right click on the Header of an assignment and choose to copy that
assignment to the existing class or ALL or Multiple classes. You can keep the existing date or change the date
on those copied assignments if you wish to use the assignment for any date other than the date the original
assignment was created for. The 1.1 version now allows you to copy assignments from previous years as well!
Next year you will be able to copy assignments from this year to the next by clicking in the term at the top left
choosing the appropriate vear and then navigating to the assignments and use the copy function to the current
year.

Current Classes (52) v
A urrent Classes (S2) ~ 7
©007-2008
Semester 1 =l

Semester 2

‘E006-2007
Semester 1
Semester 2

Preferences
Tools > Preferences > Grading
Choose whether you wish to display the lettergrade, percentage and points on the Scoresheet.
Tools > Preferences > Sections

2

Choose whether you wish to display and sort by period or section number. You can also choose to have

the section display with a custom name that is determined under Class Info.

SCORESHEET
After you have created an Assignment, Click on the Scoresheet icon at —
the top. |

80% 40/s0 40
You are now able to enter scores by clicking directly in the cell = EEEE 33
underneath the assignment. You can move down the column by clicking ... 50/50 50

on Enter or your down arrow key to enter scores. Collected

. S0JS0
! Late

50/50

1
1
! . 70% 35/50 Exemnpt

Be sure to Filter or Choose the correct Reporting Term, Category and I, 50/50 Missing
Students!!! 1. s0/s0 Clear Score

L. 50/50 Fill Scores

L... S0/S0 Show Score Inspector
You can also right click directly in that cell to: S -

1... 50/50 S0

60% 30/S0 30

1

Mark a score as Collected R <L

Mark a score as Late
Mark a score as Missing
Mark a score as Exempt
Clear a score

Fill Scores

Show Score Inspector

NOo kW

Computer[fTTH
roup
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Fill Scores

PowerSchool/Teachers Training
LOWER MERION SCHOOL DISTRICT

Click on Fill Scores or go to TOOLS > Fill Scores. You can mark assignments as Collected, Late, Exempt,

Missing AND vou can assign a comment to a particular score by clicking on Comment Bank (if your district
uses this feature) > the Comment Bank will open > double click on the comment > OK

COMMENTS

Scoresheet =~ Assignments

Students  Grade Setup Cfass Info

v.uﬁ\‘

Wﬁup

v . Category: ALL

1. Choose porking T‘ lT1
— correct ’

: e e
reporting »
Term. E o
| -~ D~
=] & S
La o =
— - — O
Student inal Grade (T1) ||| |§ S € Sg£

o0
o0
&
'
o
=)
&
1]

Mouse, Mickey g
Smith, John 2 B
Smith, Ronald © B

2. Right click in
Final Grade
Column or Tools >
Score Inspector

A blue “C” will appear next to each Final Grade that indicates a comment has been assigned to that student.

ASSIGNMENT COMMENT - If vou click on a specific score for a student in any assignment vou can also
enter a comment for that individual score! This is not the same as creating a comment for the Final Grade!
Rather this is used to communicate to parents/students your remarks for any students’ assignment’s score.

3. Click on Comment Bank
button

4, Comment Bank Screen will
open

5. Double click on correct
comment

6. Use up or down arrows to go
to next student

7. Choose correct comment
8. OK when all students have
been assigned a comment

UDWI'I
Student: Mickey arrow & w
keys
Reporting Term: T1 Y
Manual Override: [ ]
Percent: ‘
Grade:
Points: 175/200
Comment:

Displays creativity.

Computer TG
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FINAL GRADE COMMENTS and MANUALLY OVERRIDE A GRADE

You may choose to manually override a Final Grade — by right clicking in the Final Grade column OR from the
top menu choose TOOLS > Score Inspector > check the box to Manually Override in the Score Inspector
dialog box and enter the correct Percentage and Letter Grade! See Screen Shot below.

Right click within the Final Grade column and choose Score Inspector OR Click once in the Final Grade
column and go to TOOLS > Score Inspector

vindow Help

= X
:"\,;_
v il 9

de b =
3 Engl Scoresheet  Assignments.  Students Grada Setup  Class Info Rep

Fiter By: Reporting Term:

Category: [ALL | 4. ) | o
s Gra © ) }—W
nguag Grade: | A
. e +
Arts 2. Right Click in Final Grade E 5 5 5. Pointe: nja
le 6 column and select Score S =]

Inspector

Comment:

b) e, Mickey -+ .
11]{Smith, John © - ]
Srnith, Ronald [+ ] -
¥ Select Comments
Select Comments
Choose comments that should be added to this Score
Code Comment Cateqg... &
107 Meeds to improve working knowledge of art product... Art A
ats responsibility For own actions, Behavior =
7. Double click on ‘ibutes to peaceful atmosphere of group. Behavior
comment. nstrates leadership qualities, Behavior
sk wiopdYs a p05|t|ve attitude toward learning, Behawor
P isplays a spit of cooperation. e
- Behavmr
L]
-1 114 Displays self cuntrol Behavior
115 Exhibits appropriate behavior in dealing with conflict,  Behavior
116 Frequent absence from class has impacted grade. Behavior 3
i Insert Selected Comments
8. 0K
Displays a spirit of cooperation. I l Revert H Save

IMPORTANT:

If you do not wish to manually override but only enter Teacher Comments-- just click on COMMENT BANK
and double click on the appropriate comment and, last, OK. The Final Grade score will then appear with a
BLUE “C” that indicates a comment was assigned to this student for the FINALL GRADE! Click on the down or
up arrow keys within Score Inspector to assign a comment to another student REPEAT until all comments
have been assigned! If your district does not use a comment bank — you can enter any narrative comment as

well here!
logic 1
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Students
Sc0resheet signments Students  Grade Setup  Class Info Reports

Filter By: Students: ﬂu:tive v

Students Student Mumber Birthday ¥ Gender Grade Level  Home Phone

Smith, Ronalde" S 170004493 1171071999 6 516-234-5673
vlouse, Mickey © 17006707 01011900 & 516-222-1111
smith, John S 170005971 01/01/1900 M 6 516-234-5678

Be sure to chooseffilter the
correct selection of students!

You can also click on each column heading to resort students, student number, birthday, gender, grade level and

home phone in ascending or descending order.

GRADE SET UP
Term Weights

S 0

Scoresheet Assignments  Students  Grade Setup  Class Info Reports

Reporting Term

09042007 Tue
© 09/04/2007 Tue
© 124012007 Sat
@ 03/01/2008 Sat

11;‘3|]12DD? Fri
02/28{2008 Thu
06/30{2008 Mon

1. Click on the F1 Reporting Term.

2. Use Term VWeights to calculate a Final Grade at the
end of the year.
Each Trimester should be given equal weight.

3. Save

Calculate final grade using:

() Total points

(% Term weights

() Category weights

[ A Mame Weight Percent Drop Low
I T PN -
[ DIRRF 100 73.3% nja

o 100 73.3% nja

Revert

Save

Computer TG

1. Choose the
correct FINAL
TERM in the
top frame.

2. Click on Term
Weights radio
button in the
bottom Frame

3. Click on
Weight and list
the weights as
listed in the
screen shot.

4. SAVE

Note: If vou are using
Quarters or Semesters
modify the weight
accordingly!
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Category Weighing

Follow the steps in the screen shots below OR the written directions on the right.

RN o

00

1. Choose Term intop
frame.

Scoresheet Assignments  Students  Grade Setup  Class Info Reports .
2. Click on Category
Reporting Term Start End Welghts radlo bUtton m
L © 09/04/2007 Tue 06430/2008 Mon bottom frame
1. Choose Term i Ei 3. Click on +to add a
[ PR 02/28/2008 Thu { ¢
E| T3 © 03/01j2008 Sat 06/30/2008 Mon category or — 10 remove
a category.
4. Check all categories
(see box below)
5. Enter Weight.
6. Drop assignment(s) — if
you wish.
Y= T1 7. SAVE
Calculate final grade using:
() Total points
i y A | Abbreviation
&) Category weights 2. Choose Category weights prors =
z Qz
A Name Weight Percent Drop Low £ Ll
|| | Project Wa 0
T?_Jl ‘] 4.enter
1) | Quiz weight i 0
3.Clickon ¥ toada | | |Test for e 0
. each
your categories or = category
to delete a category |
add category add assignment remove
5SAVE
b | Save

Total Points

If you wish to use the Total Points method — click on Term in top frame. Choose Total Points radio button.
SAVE. You can now enter any number of possible points to each assignment you create.

Recalculate Final Scores o !
‘3 Points Possible Has Changed =
Wl keep or Adjust Scores =8
When changing the points possible for an assignment (for 2 o

example, from 10 points possible to 100), teachers can keep the
existing scores, or scale them up or down to match the new

points possible.

The Points Possible for this assignment has changed. Student scores already
exist,

Do you want to leave the scores as-is, or adjust them based on the
new points poassible?

Cancel J[ Adjust Scores ]L Keep Scores J
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Class Info

Course Name: Current Affairs Term: 2007-2008

Section Number; 3 Start: 06/01/2007 Fri

Periods/Days: 3(B) End: 05/30/2008 Fri

Room: 123 Grade Scale: Default

Custom Display Name:

Change Section Name Here

Description: This description area is used for communicating to parents your

weighting options, behavior code in your classroom, events occuring in your
classroom -- anything you want to inform your students or parents!

By changing text here -- parents are able to view your notices
immediately by clicking on the SAVE button below!

| Add Web Link

REPORTS

Attendance Grid

B -

Scoresheet  Assignments  Students  Grade Setup  Class Info Reports
Mame: A | Description:
Attendance Grid @ |Student and date arid kemplate for taking attendance

1. Choose the type of
Report

Category Total Report © Summary of category totals by section or by student
Final Grade and Comment Yeri... € Final grades and comments by reporting term
Individual Student Report
Missing Assignment

© Summary of class activity per student
© Listing of assigments that have not been scored

Scoresheet @ |Student grade and assignment data
Student Roster © student demographic information listed one row per s...
(x X =]

Attendance Grid

2. Make your selection
of options
from bottom frame

Name: Attendance Grid

Description: Student and date arid template For taking

Sections: (%) Selected Class () Active Classes

Students: (&) Enrolled Students () Selected Groups and/or Students

Current Week:

Start Date: | 09/10{2007

3. Select date frame

End Date: | 09/14/2007

4. Click on Run Report

5. Save the file to your Desktop
6. Minimize Gradebook

7. Navigate to your file

8. Open your Report

| RunReport

Computer TG

SR w

Choose the type of
Report

Make your selection of
options from bottom
frame. Don’t forget the
LAY OUT tab!

Select date frame

Run Report

Either OPEN the report
or Save the file to your
Desktop

If you have chosen
SAVE then Minimize
Gradebook

Navigate to your file on
Desktop.

Open the saved report.
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Category Total Report

Final Grade and Comment Verification Report
Individual Student Report

Missing Assignment Report

Scoresheet Report

Student Multi Section Report

Student Roster Report

The Reports listed above are all completed using the same steps listed above in the Attendance Grid Report.
The options will change based on the report. You may have to list a reporting term or the type of Report — pdf
or Excel (csv) but the steps are exactly the same!

The new LAYOUT tab allows you to include a title, a top note, a bottom note, page break options and a
signature line! Settings are remembered across sessions for future use!

We recommend that you create a folder on your Desktop named “GradeBook Reports™ so you have a place on
your Desktop you can save all of the various reports. Another recommendation is to name your report and
include the date for easier retrieval. For Example — Individual Student Report 9-15-07.pdf

The REPORT information below is taken directly from the new enhancements link above the Launch Gradebook button!

Student Roster Report
» Six blank fields added that can be named and stored.
Individual Student Report
s Include or exclude final grades, assignment info, score comments, and category totals.
+ Specify reporting terms to display.
« Assignment weighting is now displayed. Assignment and category abbreviations can be used.
+ Sorting by section, page break, and space-saving options.

Missing Assignment Report

+ Use the new Missing indicator, or continue to use unrecorded scores.
» Sort by section, or alphabetically by students across sections.

Attendance Grid Report
+ Include or exclude the date headings.
+ Select a number of days to display, rather than a specific date if you choose.
+ Allows use of this report for a variety of purposes, such as a class checklist.

Final Grade and Comment Verification Report

+ Include or exclude points, percent, and letter grade.

Computer|TTG 19
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Scoresheet Report
+ Standardization of student name appearance.

» Select which final grade columns to display.
+ Alternating line colors for enhanced readability.

GROUPS

You must first create a SE'T and then you will be able to create group(s) of students — by clicking on “ + *““ in
bottom left corner.

L P b ] e § f’=\
—Lrrent C - ‘ Once you have created a SET and then a GROUP you can hold down
= \ your CTRL key and select a group of students and drag that selection

I HR1(M-F) Homeroom Grade & y of students into the appropriate group. Each group will appear as a
I 2(F) S(Th) HR2(M, W) 7(T) Engl Scor different color. You can now create an assignment and give scores to
W 10w HRZ(Th) 7(T) Social Studic s the grouped students and Exempt everyone else not in that particular
L) 2(T,Th) 4(w) Mathematics Graq o o+ group. You are able to run reports for a group as well!
I 4(T) S(w) 7(F) English LanguadSmith, R
E] 2(W,F) English Language Arts {Smith, Jc

El HRZ(W) Technology Grade &  |Mouse, P

Cutrent C

l "B m L

fé Student G 2 B HRL{M-F) Homeraom Grade &
dent I’DUES I “
‘ntire C| — a 2(F) S{Th) HR2(M,'W) 7(T) Enal Scoresheet  Assignments  Students  Grade €
-ntire ass .
v fﬁi Egyptians ) 10wy HR2(Th) 7(T) Social Studit g, By: Reporting Term: | T1 v
i Ph h ) 2(7,Th) 4(w) Mathematics Gra T
!! P Ua = I 4(1) 5(w) 7(F) English Languag
“ SRR El 2('w,F) English Language Arts E
El HR2(W) Technology Grade &
Student Final Grade {T1) |||
< * |Curry, Penny (4] -
= 55‘;“13"'; Groups ||| |Disney, Walt (+] -
Intire Class Li, Ellen (4] -
¥ 1§} Blue Mouse, Mickey [+ ] -
> i EE - ith, 1ohn o -
) > 18 Yelow Smith, Jones (+] -
1. Click on + to create a Set Smith, Ronald © -
2. Double click on Set to give it a Smith, Student2 o -
name Smith, TrustingZ 2 -
. 2 Student, Test 4] -
3. Click on + again and Add Group I 4 -
4. Double click on Group to Testing, Student o i
give the group a name

(see above)

Computer TG
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REPORT CARD PROCESS

Standards — (only if your district uses Standards!) All Standards must be entered into PowerSchool/Teachers.
Please see page 5 of this manual for directions. Teachers using the Web Gradebook do not have the ability to
link assignments to standards (coming in version 2.0 web gradebook!) —all standards must be completed in
PowerSchool/teachers > click on Standards Summary (m) click on the (m) to enter for the whole class.

Final Grades and Teacher Comments — Can be entered one of two ways.

1. Use PowerSchool/Teachers to enter one Final Grade and a Teacher Comment — see page 5 & 6 of this
manual for directions.

2. Use PowerTeacher Gradebook to enter grades and comments by creating assignments and then
associating a comment under the Final Grade column- see page 14-15 of this manual for directions.

IMPORTANT! If using Web Grade Book, comments MUST be entered through the grade
book and not through PowerTeacher Teacher Comment entry.

After you have entered your Standards into PowerSchool/Teachers and your Final Grades through
PowerSchool/Teachers OR the PowerTeacher Gradebook your school’s PowerSchool administrator will
complete a process called “storing grades.” Only then will you be able to see your grades on the Report Card!
Standards automatically appear on the Report Card as you complete them in PowerSchool/Teachers!

Teachers will then be given either a Class Roster Report OR a DRAFT copy of the Report Card.

Admuinistrators will change Current Grade Display to “Historical” for the Term.

If any grades or comments are incorrect — the TEACHER makes the changes -- either in PowerSchool/Teachers
if that is where they originally created the grade OR in the Web Gradebook! The administrator then “re stores™
grades for your changes to appear. Please be aware that this process necessitates that everything is completed by

the deadlines given at your school.

After grades have been “re stored” schools will then print Final Report Cards onto special water-marked paper
if provided.

Report Cards are distributed.

Administrators enable Final Grade Entry options for the next Term and change Current Grade Display (current
grade) for the current Term.

Computer|TTG 21
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The information below is taken directly from the new enhancements link above the Launch Gradebook button in PowerSchoolteachers!

PowerTeacher Quick Entry Tips

To help you to quickly accomplish tasks you perform frequently, you can use the following quick entry tips,
which include a number of shortcut keys. Shortcut kevs consist of pressing one or a combination of keys on the
keyboard to complete a task. See the respective sections for detailed procedures.

Note:

If you frequently refer to the next couple of pages, you may find it helpful to print it and place it at your
workstation.

Computer|TTG 22
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Scoresheet Keyboard Shortcuts

Task Shortcut (Windows)

Do one of the following:
Assignments: Assign 100% « Enter an equal sign (=) and press ENTER to assign 100% of points
of points possible possible for the assignment
¢  Open the Score Inspector and enter an equal sign (=) in the Score field

Do one of the following:

+ Enter Col in the score field (repeat to remove)

Collected: Mark or clear a « Enter period (.) in the score field (repeat to remove)
student's assignment as « Right-click in the score field and select Collected (repeat to remove)
collected +  Open the Score Inspector and select the Collected checkbox (deselect the

checkbox to remove)
« Use Fill Scores command to apply to multiple students

Do one of the following, and enter comments in the Comment field:

Comments: Add a comment
to a student's assignment
score

Press and hold CTRLA+SHIFT+I
+ Right-click on a score field and select Show Score Inspector
s Use Fill Scores command to apply to multiple students

Do one of the following and enter comments in the Comment field:

Double-click on a student's final grade

Press and hold CTRLA+SHIFT+I

Right-click on a final grade and select Show Score Inspector
Use Fill Scores command to apply to multiple students

Comments: Add a comment
to a student's final grade

Do one of the following:

Enter Ex in the score field

Right-click in the score field and select Exempt
s  Open the Score Inspector and select the Exempt checkbox
« Use Fill Scores command to apply to multiple students

Exempt: Mark a student's
assignment as exempt

Fill Scores: Assign a score, Do one of the following:
comment, and/or flag (late,

collected, missing, exempt) « Right-click in a score field and select Fill Scores
to multiple students for an o Select Fill Scores from the Tools menu
assignment

Computer|TTG
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Late: Mark or clear a
student's assignment as late

Missing/Not Handed In:
Mark or clear a student's
assignment as missing

Override a Final Grade

Zoom In

Zoom Qut

PowerSchool/Teachers Training
LOWER MERION SCHOOL DISTRICT

Do one of the following:

+ Enter Lt in the score field (repeat to remove)

+ Enter asterisk (*) in the score field (repeat to remove)
Right-click in the score field and select Late (repeat to remove)

+  Open the Score Inspector and select the Late checkbox (deselect the
checkbox to remove)

s Use Fill Scores command to apply to multiple students simultaneously

Do one of the following:

« Enter Mi in the score field (repeat to remove)

Enter forward slash (/) in the score field (repeat to remove)

Right-click in the score field and select Missing (repeat to remove)
Open the Score Inspector and select the Missing checkbox (deselect the
checkbox to remove)

+ Use Fill Scores command to apply to multiple students simultaneously

Do one of the following and select the Manual Override checkbox:

s Double-click in a Final Grade fiecld
« Right-click in a Final Grade field and select Score Inspector
e Press and hold CTRLASHIFT+I

Do one of the following:
s Click on a final grade ficld or assignment header and press and hold
CTRLASHIFT+=
s Select Increase on the View menu
Do one of the following:
s Click on a final grade ficld or assignment header and press and hold

CTRLASHIFTH+-
+ Select Decrease on the View menu

Score Inspector Keyboard Shortcuts

Task
Navigate to the next
assignment
Navigate to the next
student

Shortcut (Windows) Shortcut (Mac)
Press and hold CTRLHAALTH+RIGHT Press and hold CTRLHYOPTION+RIGHT
ARROW ARROW
Press and hold CTRLHAALT+DOWN Press and hold CTRLTHOPTION+DOWN
ARROW ARROW
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Press and hold CTRLHOPTION+LEFT

Navigate to the previous  Press and hold CTRLAALT+LEFT

assignment ARROW ARROW
Navigate to the previous  Press and hold CTRLAALT+UP Press and hold CTRLAOPTION+UP
student ARROW ARROW

Do one of the following:

+ Right-click in a score ficld and select Score Inspector
s Press and hold CTRLASHIFT+I
+ Select Score Inspector from the Tools menu

Open Score Inspector

Main Menu Keyboard Shortcuts

Task

Copy
Cut

Hide other application windows

Shortcut (Windows)
Press and hold CTRIAC
Press and hold CTRL+X

Press and hold ALT+TAB

Hide PowerTeacher Gradebook windowPress and hold AL T+TAB

Open Assignments window
Open Categories window
Open Class Info window

Open Grade Scales window
Open Grade Setup window
Open Gradebook online help
Open New Gradebook window
Open Reports window

Open Score Inspector

Open Scoresheet window

Open Students window

Open the Preferences window
Paste

Quit PowerTeacher Gradebook
Recalculate Final Scores

Revert (discard unsaved changes)
Save

Press and hold CTRLA+SHIFT+2

Press and hold CTRLASHIFT+C
Press and hold CTRL+SHIFT+S

Press and hold CTRL+SHIFT+G
Press and hold CTRLA+SHIFT+4

Press F1

Press and hold CTRL+N

Press and hold CTRL+SHIFT+6

Do one of the following:

Shortcut (Mac)
Press and hold COMMANDHC
Press and hold COMMAND+X
Press and hold
OPTION+COMMAND+H
Press and hold COMMAND+H

Press and hold COMMANDH?
Press and hold COMMANDH+N

+ Right-click in a score field and select Score Inspector
¢ Press and hold CTRLASHIFT+I

Press and hold CTRLASHIFT+1
Press and hold CTRL+SHIFT+3
Press and hold CTRLA+,

Press and hold CTRLAV

Press and hold ALT+F4

Press and hold CTRL+SHIFT+R
Press and hold CTRL+R

Press and hold CTRLAS

Computer|TTG

Press and hold COMMANDH,
Press and hold COMMANDAHYV
Press and hold COMMAND+Q

Press and hold COMMAND+R
Press and hold COMMANDH-S
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